Start a new topic

Harley Davidson BOOM! system freezing when reading large number of tracks points.

I have a Harley Davidson BOOM! Nav system running version 1.21.3.1 software.  In the past, I was able to import Harley Davidson .gpx 1.1 route files without any problem. 

Recently, my Nav system has started hanging up when trying to open these files.  I have tried several USB sticks and several different routes with only two way-points in them.   I got to comparing Harley Ride Planner gpx files to MyRoute-app gpx files and noticed that MyRoute-app gpx files contained a lot of tracks points where there were none in the Harley Ride Planner file.  When I delete these tracks points from the MyRoute-app gpx file, my Nav system reads them just fine.  

There appears to be a very low limit to how many tracks points my Nav system can deal with.  While I have not debugged how many tracks points it can handle, I propose adding a second option to the save as feature to save a Harley Davidson Route only gpx file. 


Does any other Harley owner here use the tracks points?  To be honest, I really don't know what they are for?

gpx

1 person has this problem

Hi Ronald, 


Thank you for bringing this to our attention. 

I have informed the developers about this problem.

Do you have any idea when this started to happen? Is this something from last week or has it been acting up for a while now? 

Also, what do you mean by "hanging up", does the connector stop working? Or do you get the message that the route is exported but when you look, it's not there?


I hope to hear from you! 


Kind Regards, 


Anthony Fens

Customer Support MyRoute-app

I had had trouble importing a route to my bike a few months ago, however, it was not until this month that I had a chance to debug the issue some.

"Hanging up" -- I was referring to my BOOM! radio failing to load the gpx file and presenting me with a blank screen when I try to import a route.  Just to be clear.  I have no problem saving the route from MyRoute-app site and after downloading the route I copy it to a jump drive.  From there I attempt to import it into my BOOM! system by connecting the jump drive.  Pressing OK to the "There is no media on this drive" notice.  Selecting menu from the Navigation screen, Selecting Import from the menu screen.  Selecting my jump drive from the next menu.  Selecting the gpx file from the next menu.  At this point I see the drive light on my jump drive flash and nothing happens.  I do not get the expected menu asking me to select what I want to import.  It just hangs there.  

Please let me know if I can do any additional testing for you. 

 

Same problem here.  2016 Limited.  Updated Boom software.  The error message is that the database is full.  The limit for way point is 100, I only had 5.  But over 1000 track points.  So this is a common problem moving forward.  Is there an option to export without TRACK points?

Is this resolved?  I have the same problem.

No the issue has not been resolved.  They have added a new Save As option "Harley Davidson .gpx 1.1 (route)", however it still generates a xml .gpx file with a huge list of track points.


To work around this I have been hand editing this file and removing the track points.  gpx files, which are xml files and like html files, have beginning and ending tags that mark different sections of the data.  You need to locate and delete the "Track" section and keep just the "Route".  to do this, look for "<trk>" and "</trk>" tags.  Delete them and everything between and save your file.


You might also want to change the name of the route since MyRouteApp wants to append "Route" to the beginning of it.  This is an annoyance on the small BOOM! screen.   Look for the "<rte><name>Route-" in the first third of the file.  You can delete the "Route-" and not harm anything.


If you mess this up, try, try, try, again.


Note about Database is full issue: 

You need to be careful importing routes and select only the route.  That "Select All" button is not your friend.  If you have been importing everything, it will not be long before the BOOM! system memory is full and the only way to correct this issue is a factory reset.  Been there done that, takes a couple of hours.


When you import a route, make sure you select the route only.  There may be a list of way-points that come with it and those are what fills up your database.



xml
gpx
Login to post a comment