Start a new topic

Struggling with GPX formats!

I've been using Tyre for motorcycle route planning on my Garmin Zumo 340LM satnav for a few months now, and it's been working really well.  But I've been aware of some of its limitations (especially its use of Google rather than Garmin Here maps) and have therefore been looking into MyRoute-app as a replacement.  It's a real joy to use and plot routes on my PC, but after transferring the routes to my Garmin they just don't work right - or at least not as I want them to!


My old Tyre default GPX files were very small; they just included waypoints and no trackpoints, and worked perfectly for me.  In particular, if I accidentally overshot the turning to a waypoint, the Garmin would quickly recalculate the route, and I'd carry on.   But both GPX 1.0 and 1.1 files use routepoints/shaping points rather than waypoints, and both include trackpoints, which I really don't think I want or need!


Firstly, I can't figure out whether I should be using GPX 1.0 or 1.1 (and both of them are different to the only GPX option that Tyre provides, which I find really strange as the Tyre files are the ones which work!).  V1.1 files cause me the dreaded 'Garmin straight line' problem; but before someone tells me to switch off the 'recalculate'; option - surely I don't want to do that! Otherwise if I come off my route by mistake, I won't be directed back to it and I'll get lost?   v1.0 files do kind of work, but I am finding they are often inaccurate when it comes to (eg) advising turns, and the satnav just behaves a bit flakey and unreliable - completely unlike it does with Tyre GPX files.


I'd be really grateful for some advice, as I can see this is obviously a great app and I'd really like to be able to use and rely on it instead of Tyre.


Please, anybody? :)


I've been persevering, but still no good.   I've assumed that I need to use GPX v1.1 with my Garmin, and that for better or worse, I must live with trackpoints!   I seem to have got rid of the 'straight-line' problem; however the satnav totally doesn't do what it should - it sends me in the wrong direction, gives the wrong commands etc; hard to explain...

If you export a GPX file both the route and the routetrack are included on your Garmin device. 

One of them is prefixed with the word ROUTE and the other with TRACK. 


I would recommend using the track since the track recalculates you back to the route if you accidently miss a turn. 

You can find your tracks in you Garmin somewhere where it says 'tracks or trails'. 

Take a look at this video: https://www.youtube.com/watch?v=dcH4PbmMEmM&index=6&list=PLoRUfcAhS6_3NHmvCm_57TnvMddD2P7ZG


I hope this helps! 







1 person likes this

Thanks very much for the reply, Anthony!
I posted a reply here yesterday but it doesn't seem to have made it past moderation for some reason?   Will try again...


 So I've been persevering with GPX v1.1, and using the 'Track'-prefixed files on my Garmin Zumo 340LM.   I  created a short test route yesterday and went out to try it.   Everything worked fine, until I deliberately missed the third or fourth turning to see what would happen.  Answer - nothing!  No reaction from the satnav at all; and if I'd been somewhere unknown and unable to find my way back, I'd have been lost.   Anyway, I kept going until I came back to my route, and at that point the satnav happily kicked in again, as if nothing had gone wrong.   I tried this deliberate mistake test once more, and the same  thing happened.


I'm really confused - what's going wrong?  It's really important to me that the satnav recalculates the route if I go off piste, and that's what I thought it was supposed to do with 'tracks' and v1.1 ?


I posted a link to the route in question in yesterday's post - just in case that got the post autorejected I'll post the link again, in a separate post...


Thanks
David


<bump!>

If I knew that the recalculation problem I'm experiencing was surmountable, I'd be more than happy to pay for a GOLD subscription in order to be able to open a support ticket to get 1:1 help, because I think everything else about MRA is excellent! But the trouble is that without this vital functionality, MRA is useless to me - are you able to advise me if it can be sorted out, because otherwise it's pointless me upgrading to GOLD...


Thanks! :)

Login to post a comment