Start a new topic

GPX 1.0 Or 1.1 When Exporting?

I have a Garmin Zumo 660 and under TYRE it was very simple to get my route onto it - simply 'copy to Garmin' and the route was transferred.

When I go to export a route from MyRoute-app web, I am presented with a list of different export types from the connector. My choices are basically Garmin GPX 1.0 (old) or Garmin GPX 1.1 (new) - which one do I use? Both appear to copy to the device fine but I can't tell the difference.

The size of the exported file also seems to be a lot bigger from MyRoute-app web than it does from TYRE, is there any reason for this? I don't know what GPX file version TYRE uses but it might be helpful to know for comparison.

8 people have this question

I also wonder what GPX file version MyRoute-app web produces when the 'Save As'  function is used?

To answer my own question, using a Garmin Zumo 660, I should use the 1.0 version as otherwise the route is drawn as straight lines on the GPS if 1.1 is used. I don't know why this is but perhaps version 1.1 isn't supported on my unit, despite becoming a standard in 2004 and I bought my unit in 2010!

I would still like to know the difference between the two versions, however, and why there's only a choice of file versions on the 'Export' function?

I'm assuming from testing that when using the 'Save As' function in MyRoute-app web or 'Copy To Garmin' in TYRE that the resulting GPX file is version 1.0 as both these methods import fine on my Zumo 660.

I have to ask it to the developer.

We are still looking for a better solution, which will bring more clarity to the existing differences. The reason why the file is a lot bigger is due to the fact that it also contains the track. Some new navigation systems also support track navigation besides route navigation which makes navigating it a lot more accurate.

I have a BMW Navigator V made by Garmin and had to use GPX 1.0

Thanks Chris.

I just got MyRoute set up for use on my iMac and my iOS movie devices, and just upgraded to Gold to try to fix my issue.  My wife uses a Harley-Davidson Garmin Zumo 660 for gps on her bike.  I have tried to "Export" both "Old" and "New" files to the device, but neither comes out correctly on the device--that dreaded straight line route or not recognizing parts of the MyRoute route, that is to say, the route goes to a waypoint, then does a turn, takes different roads and gets to the next waypoint in a very circuitous way.  Have there been any recent changes to remedy such issues.  Help!!


  • The Garmin must be charged
  • The Garmin must be up-todate
  • Export with Garmin old (GPX 1.0)
  • Wait calculate the route till thre is GPS signal

Hope it helps.

Thanks this thread has been useful. On my Garmin 590 I still have to use GPX 1.0. However even using the HERE maps I still get different routing on the SatNav than shown app. I've tried shortest and quickest setting in the GPS but both times the route is the same and slightly different from the one in HERE maps. Ironically the GPS routes as per Google or TomTom mapping! Any thoughts?

I also use the Garmin 660LM.  If I export using the 'new Garmin' my Garmin will not give directions over bluetooth.  I need to use the 'old Garmin' for proper functionality.

Have you updated the software of your 660 to the latest version?

This is a very good Thread.  I have a Garmin Zumo 660 and I exported my route to the device.  Where on the device can I find the route?  It's not in custom routes...  am I missing the obvious?

We have a large group of riders that have newer Harleys with the Infotainment systems.  I have created routes and saved them as both 1.0 and 1.1 files.  When I plug in a USB stick with 1.0 routes on it, all of a sudden there are two files listed for each route, the one I originally named, and a second one that adds a "._" characters before the filename.  Example:  original file named "Practice Route", second file showing as "._Practice Route".  I cannot see these files on my Mac, or on the SD card or USB stick I save the files to for subsequent importing to the Harley system.  And, they do not show up as hidden files.  What gives?

Also, If I use the "Save As" button while still on the route page (the one that shows the google map), my Harley will not recognize the file, but if I go to "My Routes" and then hit the "..." button on the far right of the map line I want to save, the Harley will be able to then use that route.

Some of our guys have had their Infotainment Nav systems lock up when trying to import or load a route, and one guy had to take his bike to a dealer to get the nav system up and running again.  Others just can't load the routes or they have similar lock-up problems with their Infotainment systems.  

It would sure be nice to know what we may be doing wrong, as we have to assume it is either 1) the way we are creating and saving a route in MRA, or 2) it is a problem with the way we are importing the route, or 3) it is a problem with MRA itself.


You may find out more on a Harley forum than MRA.

The Harley system is I understand known for its occasionally flaky software and problems when importing GPX files generally. There are a few threads I read a while ago on mitigating problems so worth a search.

That said, the "Save As" difference that you mention certainly sounds like an MRA problem.

Certainly worth the effort to solve it as there is nothing worse than the Harley web planner!

1 person likes this